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GETTING STARTED

This work is the result of months of hard work with the
Esp32-cam board. It all started with the desire to write an
efficient, fast, configurable algorithm to perform motion

detection in real-time. Looking for learning material on the
web, I was shocked by the low quality of existing tutorials (or

the lack thereof of them).

This is why I’m writing this guide: to help beginners getting
started and mid-level programmers become experts.
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Hardware and Software Setup

Hardware choice

There are many Esp32-cam boards available to choose from.
They share most of the features; what differentiates them is
usually the PSRAM onboard, which can be:

1. non existent at all
2. 4 Mbit
3. 8 Mbit

Needless to say, the more PSRAM the better. And the more expensive
the board.

If you only want to get started and perform simple tasks (save pictures
to SD, upload pictures to Telegram or Webserver), you don’t need
PSRAM. If you want to do something more, it’s required. The 4
Mbit version will be enough for most applications and to follow all
the projects in this book.

At the beginning of each chapter, I will clearly state the requirements
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of the projects so you know if you can run it or not.
Here’s a list of a few boards that I can recommend (no affiliate link):

1. basic Esp32-cam board [https://aliexpress.com/item/100500190
0359624.html]: this is the most basic board out there. It costs less
than 10 $ and has (usually) no PSRAM. If you choose this, please
do yourself a favor and buy the dedicated programmer so you can
upload sketches with a USB cable.

2. M5Stack cameras [https://shop.m5stack.com/collections/m5-ca
meras]: there are many models available (normal lens or fisheye).
Most of them come with either 4 Mbit or 8 Mbit PSRAM. I’m
using a (retired) fisheye model and it has been working fine for
almost 4 years now.

3. Espressif Esp-Eye [https://www.digikey.com/en/products/detai
l/espressif-systems/ESP-EYE/9838645]: never used, so I cannot
state anything about it.

Software setup

To program your Esp32-cam, you need Esp32 core support in the
Arduino IDE.

Go to “Preferences > Additional Board Manager URLs” and add the
following:

https://dl.espressif.com/dl/package_esp32_index.json
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Arduino IDE Preferences

Now navigate to “Tools > Board > Board Manager”, search for “Esp32”
and install the core.
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Esp32 baords core

Next, you need to install the “EloquentEsp32Cam” library. Go to
“Sketch > Include library > Library Manager” and search for “Elo-
quentEsp32Cam”. Install the latest version.
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HARDWARE AND SOFTWARE SETUP

Install EloquentEsp32cam from Library Manager

Now you have all that’s needed to become an Esp32-cam expert.
Let’s start!
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Camera Configuration

Even though the Esp32-cam is a little, cheap board, it comes
packed with a powerful camera sensor. There are a lot of
configurations you can tweak to get the most out of it.

To find your optimal configuration (it will depend on your specific
setting and environment conditions), I suggest to load the official
“CameraWebServer” sketch, which exposes all these configurations
on a web page.
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CAMERA CONFIGURATION

Go to “File > Examples > ESP32 > Camera > CameraWebServer”

Don't forget to set your camera model and WiFi credentials!

Once uploaded, open the Serial Monitor to know the IP address of your
Esp32-cam. Then open that address in a web browser.
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Example of CameraWebServer web page

Most of the times I leave the settings at their default values, except for
the saturation: I like to increase it to have better colors.

Once you’re satisfied with your configuration, take down the values
you changed because we’re going to replicate them in code.

Play with the settings until you’re satisfied. Then take note of all the
values you changed, because we will need to replicate them in code.
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CAMERA CONFIGURATION

Camera Sensor Configuration Code

This is when we start using the “EloquentEsp32Cam” library. I promise
you will be shocked by how easy it is compared to what you find on the
internet.

Before we jump right into the code, I want to show you what you may
be accustomed to. This is the sketch from RandomNerdTutorials.com
to take a picture and save it to an SD card.

/*********
Rui Santos
Complete project details at
https://RandomNerdTutorials.com/esp32-cam-take-photo-save-microsd-card

IMPORTANT!!!
- Select Board "AI Thinker ESP32-CAM"
- GPIO 0 must be connected to GND to upload a sketch
- After connecting GPIO 0 to GND, press the ESP32-CAM
on-board RESET button to put your board in flashing mode

Permission is hereby granted, free of charge, to any person
obtaining a copy
of this software and associated documentation files.
The above copyright notice and this permission notice shall
be included in all
copies or substantial portions of the Software.

*********/

#include "esp_camera.h"
#include "Arduino.h"
#include "FS.h" // SD Card ESP32
#include "SD_MMC.h" // SD Card ESP32
#include "soc/soc.h" // Disable brownour problems
#include "soc/rtc_cntl_reg.h" // Disable brownour problems
#include "driver/rtc_io.h"
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#include <EEPROM.h> // read and write from flash
memory

// define the number of bytes you want to access
#define EEPROM_SIZE 1

// Pin definition for CAMERA_MODEL_AI_THINKER
#define PWDN_GPIO_NUM 32
#define RESET_GPIO_NUM -1
#define XCLK_GPIO_NUM 0
#define SIOD_GPIO_NUM 26
#define SIOC_GPIO_NUM 27

#define Y9_GPIO_NUM 35
#define Y8_GPIO_NUM 34
#define Y7_GPIO_NUM 39
#define Y6_GPIO_NUM 36
#define Y5_GPIO_NUM 21
#define Y4_GPIO_NUM 19
#define Y3_GPIO_NUM 18
#define Y2_GPIO_NUM 5
#define VSYNC_GPIO_NUM 25
#define HREF_GPIO_NUM 23
#define PCLK_GPIO_NUM 22

int pictureNumber = 0;

void setup() {
WRITE_PERI_REG(RTC_CNTL_BROWN_OUT_REG, 0); //disable
brownout detector

Serial.begin(115200);
//Serial.setDebugOutput(true);
//Serial.println();

camera_config_t config;
config.ledc_channel = LEDC_CHANNEL_0;
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CAMERA CONFIGURATION

config.ledc_timer = LEDC_TIMER_0;
config.pin_d0 = Y2_GPIO_NUM;
config.pin_d1 = Y3_GPIO_NUM;
config.pin_d2 = Y4_GPIO_NUM;
config.pin_d3 = Y5_GPIO_NUM;
config.pin_d4 = Y6_GPIO_NUM;
config.pin_d5 = Y7_GPIO_NUM;
config.pin_d6 = Y8_GPIO_NUM;
config.pin_d7 = Y9_GPIO_NUM;
config.pin_xclk = XCLK_GPIO_NUM;
config.pin_pclk = PCLK_GPIO_NUM;
config.pin_vsync = VSYNC_GPIO_NUM;
config.pin_href = HREF_GPIO_NUM;
config.pin_sscb_sda = SIOD_GPIO_NUM;
config.pin_sscb_scl = SIOC_GPIO_NUM;
config.pin_pwdn = PWDN_GPIO_NUM;
config.pin_reset = RESET_GPIO_NUM;
config.xclk_freq_hz = 20000000;
config.pixel_format = PIXFORMAT_JPEG;

if(psramFound()){
config.frame_size = FRAMESIZE_UXGA; // FRAMESIZE_ +
QVGA|CIF|VGA|SVGA|XGA|SXGA|UXGA
config.jpeg_quality = 10;
config.fb_count = 2;

} else {
config.frame_size = FRAMESIZE_SVGA;
config.jpeg_quality = 12;
config.fb_count = 1;

}

// Init Camera
esp_err_t err = esp_camera_init(&config);
if (err != ESP_OK) {

Serial.printf("Camera init failed with error 0x%x", err);
return;

}
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//Serial.println("Starting SD Card");
if(!SD_MMC.begin()){

Serial.println("SD Card Mount Failed");
return;

}

uint8_t cardType = SD_MMC.cardType();
if(cardType == CARD_NONE){

Serial.println("No SD Card attached");
return;

}

camera_fb_t * fb = NULL;

// Take Picture with Camera
fb = esp_camera_fb_get();
if(!fb) {

Serial.println("Camera capture failed");
return;

}
// initialize EEPROM with predefined size
EEPROM.begin(EEPROM_SIZE);
pictureNumber = EEPROM.read(0) + 1;

// Path where new picture will be saved in SD Card
String path = "/picture" + String(pictureNumber) +".jpg";

fs::FS &fs = SD_MMC;
Serial.printf("Picture file name: %s\n", path.c_str());

File file = fs.open(path.c_str(), FILE_WRITE);
if(!file){

Serial.println("Failed to open file in writing mode");
}
else {
file.write(fb->buf, fb->len); // payload (image), payload
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length
Serial.printf("Saved file to path: %s\n", path.c_str());
EEPROM.write(0, pictureNumber);
EEPROM.commit();

}
file.close();
esp_camera_fb_return(fb);

// Turns off the ESP32-CAM white on-board LED (flash)
connected to GPIO 4
pinMode(4, OUTPUT);
digitalWrite(4, LOW);
rtc_gpio_hold_en(GPIO_NUM_4);

delay(2000);
Serial.println("Going to sleep now");
delay(2000);
esp_deep_sleep_start();
Serial.println("This will never be printed");

}

void loop() {

}

It’s 136 lines without comments.
And it doesn’t include any code for the sensor settings configuration.

Let’s get a taste of what working with the “EloquentEsp32cam” library
looks like instead.

// Include the EloquentEsp32Cam library
#include "esp32cam.h"

// Instantiate the camera
Eloquent::Esp32cam::Cam cam;
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void setup() {
/**
* Most of the settings you found on the CameraWebServer
page
* are available for modification
*/

cam.vflip();
cam.hmirror();

cam.lowestBrightness(); // set brightness = -2
cam.lowBrightness(); // set brightness = -1
cam.highBrightness(); // set brightness = +1
cam.highestBrightness(); // set brightness = +2
cam.setBrightness(0);

cam.lowestSaturation(); // set saturation = -2
cam.lowSaturation(); // set saturation = -1
cam.highSaturation(); // set saturation = +1
cam.highestSaturation(); // set saturation = +2
cam.setSaturation(0);

cam.negative();
cam.grayscale();
cam.redTint();
cam.greenTint();
cam.blueTint();
cam.sepia();

cam.enableAutomaticWhiteBalance();
cam.disableAutomaticWhiteBalance();

cam.enableGainControl();
cam.disableGainControl();

16



CAMERA CONFIGURATION

cam.enableExposureControl();
cam.disableExposureControl();

cam.enableAutomaticWhiteBalanceGain();
cam.disableAutomaticWhiteBalanceGain();

cam.enableAutomaticGainControl();
cam.disableAutomaticGainControl();

cam.enableAutomaticExposureControl();
cam.disableAutomaticExposureControl();

cam.enableDCW();
cam.disableDCW();

cam.enableBPC();
cam.disableBPC();

cam.enableWPC();
cam.disableWPC();

cam.enableLensCorrection();
cam.disableLensCorrection();

cam.enableRawGamma();
cam.disableRawGamma();

// custom configuration
cam.configureSensor([](sensor_t *sensor) {
// do whatever you want with the sensor

});
}

void loop() {

}
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You have to admit that’s as clear as it can get.
You don’t have to configure every single option: just choose the one

you want to edit and delete all the others.
This is what my starter template looks like:

#include "esp32cam.h"

Eloquent::Esp32cam::Cam cam;

void setup() {
cam.vflip();
cam.highestSaturation();

}

void loop() {
}

Now that the board has been configured, it’s time to grab our first
frame!
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Taking your first picture

I f you recall from the previous chapter, capturing a frame and
saving to the SD card took 136 lines of code.

Don’t get me wrong: it’s not (only) about the number of lines
here. Some things require lengthy code to be performed and you can’t
escape it. The “EloquentEsp32Cam” library, in fact, is only hiding that
same lengthy lines from you - but they’re still there.

What should bother you is that:

1. copy-pasting 136 lines for every new project is boring
2. adding your own code in-between those lines can become messy

By eliminating the visual clutter, I help you eliminate the mental
clutter.

That said, let’s go to the code.
The sketch below only captures a frame; it doesn’t save it to anywhere

(that’s for later chapters). The main purpose of this sketch is to get you
familiar with this basic but mandatory operation.
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#include "esp32cam.h"

Eloquent::Esp32cam::Cam cam;

/**
*
*/
void setup() {

Serial.begin(115200);
delay(3000);
Serial.println("Init");

/**
* Configure camera model
* Allowed values are:
* - aithinker()
* - m5()
* - m5wide()
* - eye()
* - wrover()
*/
cam.aithinker();

/**
* Configure camera resolution
* Allowed values are:
* - _96x96()
* - qqvga()
* - qcif()
* - hqvga()
* - _240x240()
* - qvga()
* - cif()
* - hvga()
* - vga()
* - svga()
* - xga()
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* - hd()
* - sxga()
* - uxga()
*/
cam.vga();

/**
* Configure JPEG quality
* Allowed values are:
* - lowQuality()
* - highQuality()
* - bestQuality()
* - setQuality(quality), ranging from 10 (best) to 64
(lowest)
*
*. Default is highQuality()
*/
cam.highQuality();

/**
* Initialize the camera
* If something goes wrong, print the error message
*/
while (!cam.begin())

Serial.println(cam.getErrorMessage());

Serial.println("Camera OK");
}

void loop() {
/**
* Try to capture a frame
* If something goes wrong, print the error message
*/

if (!cam.capture()) {
Serial.println(cam.getErrorMessage());
return;
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}

Serial.print("Jpeg size: ");
Serial.println(cam.getFileSize());

/**
* Do whatever you want with the captured frame.
* See next examples.
*/

}

We are at 29 lines of code (without comments).
Here’s the short version.

#include "esp32cam.h"

Eloquent::Esp32cam::Cam cam;

void setup() {
Serial.begin(115200);

cam.aithinker();
cam.vga();
cam.highQuality();

while (!cam.begin())
Serial.println(cam.getErrorMessage());

Serial.println("Camera OK");
}

void loop() {
if (!cam.capture()) {

Serial.println(cam.getErrorMessage());
return;
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}

Serial.print("Jpeg size: ");
Serial.println(cam.getFileSize());

}

Hopefully, you can understand exactly what’s going on. If you want to
change something, you know the exact line you need to look at.
No clutter.

Take some time to familiarize with this base template, because we’ll
use it in every single sketch of this book.

_____________________________________________________

This closes this first, short part on the “Getting Started with the Esp32-
cam”. The code here does almost nothing useful, but it will serve as a
foundation for the rest of the book.

Now let’s move to the basics of a camera:

1. Live Video Streaming in the Browser
2. Save Pictures to SD card
3. Pictures Browser in the Browser
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